suckless-extra

A collection of gentoo ebuilds for suckless programs as well as their dependencies and setup scripts
git clone git://git.stellar-nexus.ru/suckless-extra
Log | Files | Refs

bgs-0.8.ebuild (848B)


      1 # Copyright 2024 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit toolchain-funcs
      7 
      8 DESCRIPTION="extremely fast and small background setter for X."
      9 HOMEPAGE="https://github.com/Gottox/bgs"
     10 SRC_URI="https://github.com/Gottox/bgs/archive/refs/heads/master.tar.gz -> ${P}.tar.gz"
     11 
     12 S="${WORKDIR}/${PN}-master"
     13 
     14 LICENSE="MIT"
     15 SLOT="0"
     16 KEYWORDS="~amd64"
     17 IUSE="xinerama"
     18 
     19 DEPEND="
     20 	media-libs/imlib2
     21 	x11-libs/libX11
     22 	xinerama? ( x11-libs/libXinerama )"
     23 RDEPEND="${DEPEND}"
     24 
     25 src_prepare() {
     26 	default
     27 
     28 	sed -i \
     29 		-e "/^\(LDFLAGS\|CFLAGS\|CPPFLAGS\)/{s| = | += |g;s|-s ||g}" \
     30 		config.mk
     31 }
     32 
     33 src_compile() {
     34 	if use xinerama; then
     35 		emake CC="$(tc-getCC)" bgs
     36 	else
     37 		emake CC="$(tc-getCC)" XINERAMAFLAGS="" XINERAMALIBS="" bgs
     38 	fi
     39 }
     40 
     41 src_install() {
     42 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     43 }