suckless-extra

A collection of gentoo ebuilds for suckless programs as well as their dependencies and setup scripts
git clone git://git.stellar-nexus.ru/suckless-extra
Log | Files | Refs

smatrix-1.0.ebuild (521B)


      1 # Copyright 2024 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit toolchain-funcs
      7 
      8 DESCRIPTION="simple cmatrix clone"
      9 HOMEPAGE="https://sr.ht/~rjraymond/smatrix/"
     10 SRC_URI="https://gentoo.stellar-nexus.ru/${PN}/${P}.tar.gz"
     11 
     12 LICENSE="GPL-3+"
     13 SLOT="0"
     14 KEYWORDS="~amd64"
     15 
     16 src_prepare() {
     17 	default
     18 
     19 	sed -i \
     20 		-e "s/gcc/${CC}/g" \
     21 		-e "s/-o smatrix/-o smatrix ${LDFLAGS}/g" \
     22 		Makefile || die
     23 }
     24 
     25 src_compile() {
     26 	emake CC="$(tc-getCC)"
     27 }
     28 
     29 src_install() {
     30 	dobin smatrix
     31 }